Как прошить TP-LINK TL-WR841ND

Настройка IPTV на TP-Link TL-WR841ND

В том случае, если ваш провайдер предоставляет услугу цифрового интерактивного телевидения, то нужно задать некоторые настройки на маршрутизаторе. Сделать это можно на кладке “Сеть” – “IPTV”.

Проверьте включен ли “IGMP Proxy”, выберите режим “Мост” и выберите номер LAN порта, который (или которые) будут отведены под IPTV. В этот порт нужно подключить приставку.

Если после сохранения настроек и перезагрузки TL-WR841ND IPTV не заработает, то смотрите статью: настройка IPTV на роутерах TP-Link. Там я описывал все более подробно. Возможно, в вашем случае нужно прописать еще VLAN ID.

45

Сергей

TP-Link

Поиск прошивки

Прибор конфигурируется исключительно через свой интерфейс. Всё, что вам необходимо — вписать 192.168.0.1

На следующем этапе важно правильно заполнить поля login/pass (admin/admin подходит для новых маршрутизаторов). Если использовать эти данные для авторизации не удалось, выполните сброс параметров, на десять секунд зажав reset

В основном окне интерфейса можно найти вкладку «Состояние», где прописывается версия устройства и ПО. Изучив название своей модели, перейдите на сайт фирмы-разработчика. Здесь, в разделе «Загрузки» следует выбрать свою модель и скачать файл, расположенный в самом верху списка (он, обычно, самый новый).

При установке файла обновления, предназначенного для другого роутера, вы рискуете навсегда испортить работоспособность TP-LINK TL-WR841ND. В случае такой ошибки рекомендуем сразу же нести оборудование в сервисный центр (есть возможность, что опытные специалисты справятся даже с такой неурядицей).

Нужно удостовериться, что вы выбрали правильно наименование модели? Переверните роутер, и изучите этикетку, расположенную на дне. Здесь также будет указана версия изделия.

Установка прошивки

Усовершенствовать работу TP-LINK TL-WR841ND не трудно, всё происходит в несколько нажатий. Лучше сразу записать свои настройки, чтобы после прошивки можно было быстро восстановить нужную конфигурацию. Можно задействовать и альтернативные варианты — сохранить файл с настройками (такая опция также предусмотрена в интерфейсе), или же сделать скриншоты. Резервную копию делают в одноимённом пункте подменю раздела «Системные инструменты». В файле config.bin записаны все необходимые настройки.

Если вам удалось заполучить ПО для TP-LINK TL-WR841ND с сайта разработчика, разархивируйте его на ПК в удобное место. Перед прошивкой следует установить кабельное соединение (никогда не обновляйте технику через соединение Wi-Fi). Рекомендуем подключить роутер к ИБП, чтобы процесс обновления не оборвался из-за неполадок с электросетью.

Ещё одна деталь — отсоедините провод провайдера от роутера, это может помешать настроить изделие правильно.

Затем кликните на пункт «Обновление встроенного ПО» и выберите файл с *.bin расширением. Осталось кликнуть по клавише «Обновить» и, процедура прошивки начнётся.

Всё это займёт две-три минуты. Не рекомендуем в это время менять что-либо в роутере TP-LINK TL-WR841ND или ПК. По окончании обновления, прибор выполнить самостоятельную перезагрузку.

Осталось только вернуть прежние параметры, воспользовавшись формой восстановления в интерфейсе. TP-LINK TL-WR841ND готов исполнить все запросы!

Рекомендации от опытных юзеров: если работа устройства не наладилась даже после установки самого свежего ПО, попробуйте откатиться немножко назад, то есть скачать старый вариант прошивки. В отдельных случаях производитель не успевает настроить новую микропрограмму для стабильной работы, в ней могут быть недочёты.

Надеемся, наши рекомендации помогут настроить прибор быстро и правильно. Желаем удачи!

Open Source Code For Programmers (GPL)

Please note: The products of TP-Link partly contain software code developed by third parties, including software code subject to the GNU General Public Licence (“GPL“), Version 1/Version 2/Version 3 or GNU Lesser General Public License (“LGPL”). You may use the respective software condition to following the GPL licence terms.

You can review, print and download the respective GPL licence terms here. You receive the GPL source codes of the respective software used in TP-Link products for direct download and further information, including a list of TP-Link software that contain GPL software code under GPL Code Center.

Подключение

Прежде чем выполнять подключение роутера Tp -Link Tl Wr841n, нужно ответить на вопросы:

Каким образом он будет настраиваться?

Посредством проводного соединения и компьютера, или телефона и любого другого беспроводного девайса?

Для роутера Tp-Link Tl Wr841n настройка возможна посредством проводного соединения, беспроводного или при помощи специального приложения, которое можно найти в магазинах. Есть версии для iOS и для Android.

Если подключение будет беспроводным, адрес сети надо искать на наклейке на нижней панели. Сеть без пароля, но в отдельных версиях прошивок он бывает. Его указывают там же. После этого маршрутизатор устанавливается на ровную поверхность или крепится на стену. Антенны отгибаются в вертикальное положение, где фиксируются. Кабель провайдера устанавливается в синее гнездо.

В случае проводного соединения компьютер подключается к одному из жёлтых гнёзд. Для беспроводного сеть появится в поиске после включения и загрузки устройства. Если Wi-Fi для настройки Wr841n нет, надо проверить кнопку на корпусе. Иногда она там физически отключена.

Настройка интернета

Так как эта часть вызывает больше всего вопросов, раздел будет писаться в виде пошаговых инструкций на русском языке с детальным указанием всех настроек для Tl Wr841n.

Все параметры, в том числе и настройка IPTV, о которой чуть ниже, находятся в четвертом блоке левого меню.

«Сеть»

У беспроводной сети свой блок в меню. Для интернета — страница WAN.

Динамический тип подключения

Если доступ к сети интернет провайдер предлагает посредством динамического подключения (когда он выдаёт все необходимое сам), в строке «Тип подключения WAN» выбирается «Динамический IP-адрес» и страница принимает следующий вид:

Иногда нужно пару раз нажать «Определить», чтобы подключение заработало. Остаётся нажать кнопку «Сохранить», чтобы все параметры вступили в силу.

Статический

Этот вариант чуть посложнее, потому как все параметры придётся вводить руками. «Тип подключения WAN» — «Статический IP-адрес».

Все данные есть в договоре, и если быть внимательным, проблем не возникает. Интернет поднимается сразу.

PPPоE

Для Ростелеком PPPоE настраивается не сложнее. Для типа подключения выбирается «PPPoE» или «Россия PPPoE» (часто они совмещены).

Стандартно вводится «Имя пользователя» и «Пароль», который повторяется. Их выдаёт поставщик — нужно смотреть договор с ним.

Если есть, устанавливается «Вторичное подключение». Для Ростелекома — «Статический IP».

На следующем шаге устанавливается «Режим подключения WAN». Чаще всего пользователи ставят переключатель в положение «Подключить автоматически». Вариантов тут много, выбирают на своё усмотрение.

Другие провайдеры, использующие этот же тип подключения, могут потребовать дополнительные настройки. Если этот так, в договоре будут какие-то обозначения со следующего скрина.

Этот экран открывается нажатием копки «Дополнительно» на странице. Пояснений не будет: надо просто выставить всё, что требует поставщик. Обновление настроек — кнопка «Сохранить».

PPTP

Мобильные операторы предлагают пользователям VPN соединение по протоколам Pptp или L2tp. Для этих соединений характерно указание адреса сервера для соединения в дополнение к имени пользователя и паролю.

Если поставщик предлагает такое соединение, в выпадающем списке «Тип подключения WAN» ставится значение «PPTP/ Россия PPTP».

Заполняются поля. Обычно адрес сервера настраивать и не надо, да поставщик и не даёт этих данных. Но если у пользователя уникальный тип подключения, для полностью ручной настройки нужно выставить переключатель в середине страницы в положение «статический IP» и настроить все параметры вручную.

 L2TP

Хорошим примером и для предыдущего случая станет настройка L2tp для Билайн на Tp-Link Tl Wr841n. «Тип подключения WAN» — «L2TP/ Россия L2TP».

  1. «Имя пользователя» — из договора;
  2. «Пароль» — там же;
  3. IP-адрес/Имя сервера — tp.internet.beeline.ru
  4. Подтверждение — кнопка «Сохранить».

Клонирование МАС

Если соединение настроено правильно, а страницы всё равно не грузятся, руководство пользователя рекомендует зайти на страницу «Клонирование MAC-адреса» и сменить адрес маршрутизатора. Честные провайдеры обычно указывают это в бумагах, но некоторые «забывают», и если адрес устройства, ранее связанного с провайдером, изменился, вопрос доступа решается только общением с техподдержкой.

Но зачем кому-то знать, что пользователь купил роутер? На этой странице нажатием одной кнопки можно восстановить (для провайдера) адрес подключённого устройства.

Basic configuration

With BARRIER BREAKER (Bleeding Edge, r40867)

Tested with the wr841n v9 with or better . The system supports multiple virtual access points.

Modify the files that follows according to your needs (and, in the case, search for the file definition here in the wiki to understand how it works)

etc/config/wireless
config wifi-device  radio0
        option type     mac80211
        option channel  9 #same channel of the existing wifi network
        option path     'platform/qca953x_wmac'
        option txpower  12 #this depends on your needs, default is 20 dBm. Lower it is healthier (citation needed)
        # REMOVE THIS LINE TO ENABLE WIFI:
        #option disabled 1

config wifi-iface
        option device   radio0
        option network  lan
        option mode     ap
        option ssid     'This_is_a_new_wifi_network'
        option encryption       psk2 #wpa2 psk
        option key      'this_is_the_wifi_password'

config wifi-iface
        option device   radio0
        option network  wan
        option mode     'sta'
        option ssid     'This_is_the_name_of_the_existing_wifi_network'
        option encryption       psk2
        option key      'this_is_the_wifi_password_to_get_the_connection'
etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'here is written something, no need to modify it'

config interface 'lan'
        option ifname 'eth0'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.11.1' ä modify this according to you needsfor the lan network
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        #option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4'
etc/config/dhcp

Pratically unchanged

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config dhcp 'wan6'
        option dhcpv6 'hybrid'
        option ra 'hybrid'
        option ndp 'hybrid'
        option master '1'
etc/config/firewall

Pratically unchanged because the “client” wifi is connected to the “wan” interface, while the “repeater” wifi is connected to the lan interface, thus the firewall is basically already configured.

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan
Final actions

Just be sure that the files are saved. To edit the files on windows, either use vi on the openwrt, check for a tutorial online, the basic commands are not difficult; or use winscp with a SCP connection and edit the files with an editor on windows. Then reboot the system and check for the wifi connection.

Remember that if the “client” wifi doesn’t work, won’t work also the repeater wifi network.

attitude_adjustment 12.09 (final)

The default wireless configuration is different, for example
there is no: ‘ .
Further investigation shown that the wireless is able to provide an AP
if connected to whatever interface defined in ,
while for ‘sta’ mode (a wifi client) it is possible to obtain it only if
the interface connected to the wireless configuration is not using the option nor having a relation to a switch with more than one port (for example if with eth0 we define a switch over multiple ports) Note: would be better to check this statement more thoroughly.

For example, with the configuration reported above for barrier breaker, the wlan is linked with the wan side, that is using no switch interfaces nor bridge protocol. This works too for 12.09.

Поддерживаемые версии

Версия/Модель Версия OpenWrt Скачать последнюю версию Примечание
v1 10.03 и новее 15.05.1 Добавлена поддержка
v3 10.03 и новее 15.05.1 Отчет
v5 10.03 и новее 15.05.1
v7 12.09 и новее 15.05.1Полностью функционален
v8 (китайская версия) Trunk r29631(измененная) ? Только 2МБ встроенной памяти, требуется аппаратная модификация
v8 (международная) 12.09 и новее 18.06.2
v9 14.07 и новее 15.05.1
v10 15.05.1 15.05.1
v11 образ от v10 или trunk ? При сравнении плат v10 и v11 различия только во флеш памяти. Можно использовать образы v10 c sysupgrade -F, игнорируя проверку версии. Так же по сравнению с v10, антенны имеют другую форму (как на Archer C7), и WAN LED теперь двухцветный, зеленый и оранжевый. Образ 15.05.1 r49389 работает из коробки.

Как прошить роутер TP-Link

Обзор и настройка модема D-Link Dir-320 После того как пользователь получил данные о ревизии сетевого устройства, необходимо зайти на офсайт вендора и скачать правильную версию прошивки. Ссылка на сайт: https://www.tp-link.com.

  • Выбираем модель TP-Link. Для примера взята модель TL-WR740N, переходим в раздел «Поддержка».
  • Производитель предлагает выбрать версию ревизии.

Прошивки ПО для TP-Link-роутеров хранятся на сайте в зависимости от версий. Также прилагается подробная инструкция по обновлению в видеоформате и FAQ – наиболее часто встречающимся вопросам-ответам.

Скачиваем прошивку. Она представляет собой архив. Его необходимо распаковать на локальном диске, чтобы получить доступ к самой прошивке. Обычно программа представлена в виде файла с расширением .bin, но в старых моделях еще встречается файл .ras. Это устаревший вариант микрокода, не используемый в современных роутерах для обновления.

Далее переходим на веб-ресурс по управлению роутером, чтобы перепрошить его через веб-интерфейс. Прежде чем проводить какие-либо изменения в системе, сделайте резервную копию настроек. Поступаем следующим образом.

  1. Переходим в «Системные инструменты», потом – «Резервную копию» и «Восстановление».
  2. Выбираем пункт «Резервная копия».
  3. Указываем путь для сохранения и нажимаем ОК:

После создания копии переходим к разделу «Обновление встроенного ПО»:

  1. Нажимаем «Выберите файл», указываем скачанный дистрибутив:
  2. Нажимаем кнопку «Обновить». Процесс займет несколько минут.

После завершения процесса роутер автоматически перезагрузится. Его настройки сбросятся на заводские.

Существуют и другие способы, чтобы прошить модем TP-Link до актуальной версии.

Прошивка через USB-порт

Роутеры TP-Link, у которых в наличии есть USB-порт, способны получать актуальную версию ПО через флешку. Для этого необходимо загруженный дистрибутив скопировать на флеш-карту, предварительно отформатировав ее.

Следующий шаг – подключение ее через USB-порт к оборудованию. Далее повторяем шаги, описанные выше. То есть, заходим на веб-интерфейс оборудования в раздел с обновлением микропрограммы. Во время выбора файла указываем путь к USB-накопителю, на котором лежит дистрибутив.

Нажимаем «Обновить», ожидаем окончания процесса. Данный способ подходит, если сетевое устройство TP-Link находится на удаленном расстоянии от рабочей станции, и роутер напрямую не подключен ни к одному ПК.

Прошивка через мобильное приложение TP-Link Tether

Обновление прошивки на роутере TP-Link также производится через мобильное приложение. Ниже приведены ссылки для скачивания прошивок с магазина интернет-приложений:

  1. Android: https://play.google.com/store/apps/details?id=com.tplink.tether&hl=ru.
  2. iOS: https://itunes.apple.com/ru/app/tp-link-tether/id599496594?mt=8.

Стоит сказать, что у приложений есть список совместимости. Он находится в описании к ПО. Производитель официально заявляет, что список со временем будет пополняться.

Чтобы перепрошить роутер «ТП-Линк», надо скачать приложение, включить «вай-фай» на мобильном устройстве. Далее найти модель, микрокод которой надо обновить, подключаемся к ней через TP-Link Tether. Сетевое оборудование попросит пользователя ввести учетные данные.

После прохождения процедуры авторизации, попадаем в главное меню. В нем нужно посмотреть список подключенных устройств к сетевому оборудованию, установить параметры родительского контроля или изменить конфигурацию подключения к сети «Интернет».

К сожалению, обновить прошивку роутера через мобильное приложение теперь нельзя. На текущий момент функция недоступна.

Альтернативные версии прошивок

Кроме официальных версий прошивок для сетевого оборудования TP-Link, существуют и альтернативные сборки. Они созданы инициативными разработчиками для расширения функциональных возможностей заводских установок роутеров TP-Link для домашнего пользования, а также для точек доступа Auranet.

  • Программное обеспечение DD-WRT представляет собой альтернативный вариант микрокода, собранного на основе ядра OC семейства Linux. С его помощью любой роутер превращается в домашний медиасервер. Ссылка: ftp://ftp.dd-wrt.com/betas/.
  • Вторая, не менее известная прошивка, – OpenWrt. По сравнению с предыдущей представляет собой не готовый конфиг, а полноценный дистрибутив, собираемый пользователем самостоятельно под свои цели. Программа рассчитана на людей со знаниями в области сборки конфигураций из репозитория Linux-систем.

Способ обновления у них такой же, как и у официальных прошивок.

Обновление

Как известно, все манипуляции по конфигурированию TP-LINK TL-WR841N выполняются в интерфейсе. В него легко попасть, достаточно в браузере вписать 192.168.0.1. Параметры для входа могут быть разными, если только вы меняли их при первоначальной настройке. Для нового оборудования подходят параметры admin/admin.

После этого вы увидите меню интерфейса. Прошивка ставится в пункте Frimware upgrade раздела System tools.

Осталось только указать место, где хранится ранее скачанный файл *.bin. Для этого кликните по клавише «Обзор» и пропишите путь. Затем выполните команду «Открыть».

Последний этап — начать обновление, нажав на Upgrade. На экране можно будет увидеть окно с надписью «Processing…». Процедура выполняется определённое время, в этот период не советуем отключать ПК или роутер. Приняв новую прошивку, изделие самостоятельно перезагрузится.

При следующем входе система попросит ввести login/pass, иначе попасть в меню не удастся. Вас и в данном случае выручат параметры admin/admin, поскольку устройство было сброшено к стандартным настройкам. Советуем сменить стандартные данные для входа, после чего загрузить ранее сохранённый файл конфигурации, это поможет полноценно работать с прибором. Теперь можно наслаждаться максимально эффективной конфигурацией TP-LINK TL-WR841N.

Hardware Mods

USB 1.1 Port

Tested on WR841n_v5.1

Attention. Firmware of TP-Link TL-MR 3420 is coming to WR841ND v7.2 – verified. (OpenWrt Firmware Attitude Adjustment (r28380) / LuCI Trunk (trunk+svn7612))
But working usb port has not been verified. Probably enough to use this firmware, but do not compile a new one 🙂

Overview of the board:

Soldering (wire with red accent means D+). R185 and R183 can be shorted then D+/D- will appear in J1.

To get working USB the new firmware build is required. Files to edit are listed below:

1. Edit file target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr841nd.c

    Add line #include "dev-usb.h" after line #include "dev-leds-gpio.h"
    Add line ar71xx_add_device_usb(); before line ar71xx_add_device_mdio(0x0);

2. Edit file target/linux/ar71xx/files/arch/mips/ar71xx/setup.c

   Add line ar71xx_pll_wr(0x08, 0x00001030); before line ar71xx_detect_mem_size();

3. Edit file target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig:

config AR71XX_MACH_TL_WR841N_V1
        bool "TP-LINK TL-WR841N v1 support"
        select AR71XX_DEV_M25P80
        select AR71XX_DEV_PB42_PCI if PCI
        select AR71XX_DEV_DSA
        select AR71XX_DEV_GPIO_BUTTONS
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
        default n

For newer version of trunk (as of 2013 March)
1.Edit file target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr841n.c

    Add line #include "dev-usb.h" after line #include "dev-leds-gpio.h"
    Add line ath79_register_usb(); after line ath79_register_eth(0);

2. Edit file target/linux/ar71xx/generic/profiles/tp-link.mk, add packages in the definition of TLWR841 as following.

define Profile/TLWR841
	NAME:=TP-LINK TL-WR841N/ND
	PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
endef

i.e L7805 with 470uF and 100uF can be used to obtain 5V from the stock power supply.

NOTE: in case of v5.1 sections for WR741N instead of WR841N_V1 have to be edited (Kconfig, mach-tl-wr741nd.c).

USB 2.0 Port on v7

tested with WR841 v7.1 and trunk revision 30430. New patch for rev. 32461 available

Hardware mod is on pictures, nothing changed.
External Link

Kernel mod is different, because new kernel version is released in revision 30430.

Here is patch for kernel 3.3: http://mysicka.ics.muni.cz/openwrt/usb-patch-final.patch

Apply this patch and build…

USB 2.0 Port on v8

I haven’t tested this, but it appears to show where the USB D+ and D- pins can be found on the AR9341: http://ge.tt/m/2IKNi5l/

16M Flash & 64M RAM on v8 (China)

v8 (China) uses EON 2M flash, replace with Winbond W25Q128FVSG

Original RAM chip 16M ZENTEL A3S28D40FTP, replace RAM chip Hynix HY5DU121622DTP 64M (DDR)

updated v8 firmware successfully

Hardware info:

CPUAtheros AR9341 rev 1
Memory64MB DDR
FlashWinbond W25Q128 @ 20MHz (16MB)
ETHAtheros AR8228/AR8229 rev 1
ClockCPU: 560MHz, DDR: 400MHz, AHB: 200MHz, Ref: 25MHz

NOTE: ART partition can be extracted from original flash (EON 2M) at last 64K area, address as 0x1F0000. ART data need to be appended to new flash manually, otherwise an ar934x_wmac error occurs without wifi function.

64MB RAM Mod v7

Working chips:

  • Hynix HY5DU121622DTP-D43 (From Mustang DDR SO-DIMM 512 MB)
  • Hynix HY5DU121622CTP-D43 (From Hynix DDR SO-DIMM PC2700S-25330 512MB DDR 333MHz CL 2.5
  • Hynix HY5DU121622AT-J (From DDR 256MB PC400 (BUD968RA))
  • Infineon HYB25D512160BE (From Infineon DDR SO-DIMM 512 MB)
  • Elpida EDD5116ADTA-6B-E (From Elpida DDR SO-DIMM 512 MB)
  • Elpida EDD5116AFTA-5B-E (From Elpida DDR SO-DIMM 512 MB)
  • Samsung K4H511638C-UCB3 (From Samsung DDR SO-DIMM 512 MB)
  • EtronTech EN6AB160TSA-5G (DDR400 200MHz)

ДЛЯ ОБНОВЛЕНИЯ

ВАЖНО: Чтобы избежать проблем при обновлении ПО, пожалуйста, прочитайте следующую информацию по процедуре обновления. Проверьте соответствие аппаратной версии и версии ПО. Установка неправильной версии ПО может повредить ваше устройство и аннулировать гарантию

(Обычно V1.x =V1)

Установка неправильной версии ПО может повредить ваше устройство и аннулировать гарантию. (Обычно V1.x =V1)

Проверьте соответствие аппаратной версии и версии ПО. Установка неправильной версии ПО может повредить ваше устройство и аннулировать гарантию. (Обычно V1.x =V1)

НЕ рекомендуется устанавливать версию ПО, не предназначенную для вашего региона. Нажмите здесь для выбора региона и загрузите наиболее актуальную версию ПО.

  • НЕ отключайте питание во время процесса обновления, поскольку это может нанести урон маршрутизатору
  • НЕ обновляйте ПО маршрутизатора по Wi-Fi, за исключением тех случаев, когда это является единственно возможным способом.
  • Рекомендуется, чтобы все пользователи прекратили использовать все интернет-приложения на компьютере или отключили сетевой кабель от клиентских устройств перед обновлением. 

Примечание: Конфигурационные файлы могут быть некорректно установлены на новые версии встроенного ПО, требующие сброса на заводские настройки.

Рекомендации по обновлению ПО: Wi-Fi роутер, Wi-Fi роутер с модемом ADSL2+, Усилитель Wi-Fi сигнала

TL-WR841N (RU) _V13_191015
Дата публикации: 2019-12-20 Язык: Русский Размер файла: 6.11 MB

Modifications and Bug Fixes:
1. Optimized system stability and reliability.
2. Added LED Control function.
3. Supported HTTPS web management.
4. Optimized PPPOE module which could provide more stable connection.
5. Improved stability of L2TP and PPTP connection.
6. Fixed some security issues.

Notes:
For TL-WR841N RU v13.

TL-WR841N (RU) _V13_180330
Дата публикации: 2018-05-21 Язык: Русский Размер файла: 4.58 MB

Исправления и улучшения:
1. Исправлена ошибка, при которой при определённых условиях не работала функция MAC Clone.
2. Исправлена ошибка, при которой некоторые беспроводные устройства, подключаемые к основному роутеру в режиме RE, не могли пропинговать основной роутер.
3. Исправлена ошибка, при которой устройства Android 7.0 не могли выходить в интернет при нестабильной работе сети.
4. Исправлена ошибка, при которой при использовании режима повторителя (repeater)в определённых условиях не удавалось войти в веб-интерфейс управления.
Новые функции и улучшения:
1. Поддержка SNMP и мониторинга пропускной способности (Throughput Monitor) в режиме точки доступа (AP mode).
2. Поддержка перезагрузки по расписанию.

Примечание:
Настройки вашего устройства будут сброшены после перехода на данное ПО. Вам потребуется выполнить настройку устройства повторно – просьба не восстанавливать файл резервной копии настроек.

TL-WR841N (RU) _V13_170713
Дата публикации: 2017-07-13 Язык: Русский Размер файла: 4.50 MB

Modifications and Bug Fixes:

Новые функции/улучшения:
1. Добавлены режимы работы Точка доступа/Усилитель сигнала/WISP.
2. Обновлен список провайдеров в мастере быстрой настройки.
3. Установлена версия IGMP V3 по умолчанию.
4. Исправлена проблема маршрутизации для оператора Зеленая точка.
5. Исправлена проблема долгого переподключения PPTP/L2TP.
6. Исправлена проблема рассыпания IPTV в некоторых условиях.

Notes:

1. Для TL-WR841 (RU) _V13.
2. Ваши настройки будут утеряны после обновления.

Прошивка DD-WRT

Когда я столкнулся с необходимостью прошивки своего старого TP-link TL-WR841N мой выбор пал на DD-WRT. На сайт разработчиков я забрел случайно, когда пытался выяснить характеристики своего Wi-Fi роутера, которые нигде не указываются (стыдно ведь!).

Прошить можно любой роутер, под который уже есть прошивка в базе. Заходим на сайт DD-WRT, кликаем Router Database. На момент написания статьи в базе 814 моделей, под которые прошивка доступна для скачивания.

В поисковую строку вводим название своего роутера полностью, либо только производителя. Я ввожу TP-link 841 и получаю 9 записей, где:

  • Manufacturer — производитель (D-link, TP-link, Asus и.т.д)
  • Model — Модель роутера
  • Revision — Ревизия! Будьте внимательны, на наклейке и коробке роутера указывается ревизия. Под одной моделью роутеры выпускаются не один год и в них меняется начинка, меняются компоненты. Соответственно под разные ревизии разные прошивки. По факту это уже другой роутер и прошивка не стартанет. Получим кирпич.
  • Supported — поддерживается ли ревизия прошивкой. Последняя ревизия 841 пока не пашет.
  • Activation required — Требуется активация. На то, что у нас продается я не встречал ни одной записи где она требуется.

У меня ревизия роутера 11.x. Открываю строку со своей ревизией и вижу два основных блока. Блок с характеристиками роутера (1), блок загрузки прошивки (2).

  • Webwert to Stock — файл для отката с DD-WRT на официальную прошивку.
  • DD-WRT Factory image — файл для прошивки c официальной на DD-WRT
  • DD-WRT Webupgrade — обновление DD-WRT до DD-WRT свежей версии.

Все манипуляции производятся через веб-интерфейс в разделе обновления ПО вашего маршрутизатора. Никаких проводов и пайки. Всегда есть возможность безболезнено вернуться на сток. Вероятность получить кирпич минимальна при правильном подборе ревизии и модели своего маршрутизатора.

Всем удачной прошивки!

P.S. Почему Tp-Link TL-WR841N на этой стабильной прошивке я сменил на Xiaomi 3G.

Поделитесь в социальных сетях:FacebookTwitterВКонтакте
Напишите комментарий